Degraded performance on adepci2

Incident Report for Act-On Software

Resolved

We have resolved this issue. If you continue to experience this problem, please let our support team know here so we can investigate further.
Posted Mar 18, 2025 - 07:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2025 - 05:20 PDT

Investigating

We are currently experiencing slowness issues for customers on adepci2. Our team is actively investigating the matter and will provide updates here as soon as they are available.
Posted Mar 18, 2025 - 04:26 PDT
This incident affected: Act-On Application.