Degraded Performance on aorpci4

Incident Report for Act-On Software

Postmortem

Summary

In the early hours of June 8, Act-On customers experienced an inability to log in or access the platform. Following initial recovery, some customers experienced continued slow performance while background systems finished restoring to a healthy state. All services were fully restored by approximately 7:30 AM PT.

Root cause

The incident was caused by an internal server fault that triggered an unexpected restart. Following the restart, a number of background processes responsible for maintaining platform performance needed time to complete, which contributed to the period of degraded performance experienced by some customers.

We have identified the underlying cause and are taking steps to prevent a recurrence.

What we are doing about it

  • We are updating core server components to address the fault that triggered the restart.
  • We are reviewing our internal monitoring configuration to reduce the likelihood of this type of fault occurring under high load.
  • We are investigating the conditions that led to elevated server load in order to implement longer-term stability improvements.
Posted Jun 08, 2026 - 09:23 PDT

Resolved

We have resolved this issue. If you continue to experience this problem, please let our support team know here so we can investigate further.
Posted Jun 08, 2026 - 09:15 PDT

Monitoring

A fix has been deployed, and service has been restored.

While the platform is now available, some services may take a short time to return to optimal performance as systems fully recover. We are continuing to monitor the environment closely to ensure stability and confirm that all services return to normal operation.
Posted Jun 08, 2026 - 07:39 PDT

Investigating

We are currently investigating reports of degraded performance affecting accounts hosted on aorpci4.

Our team is actively investigating the issue and will provide updates as soon as more information becomes available.
Posted Jun 08, 2026 - 06:45 PDT
This incident affected: Act-On Application.