Logins to Connect

Incident Report for Act-On Software

Resolved

Our helpdesk provider has resolved the issue. Act-On Connect is now fully operational.
Posted Mar 15, 2023 - 17:21 PDT

Update

We are continuing to investigate this issue.
Posted Mar 15, 2023 - 17:18 PDT

Investigating

Our helpdesk provider has resolved the issue. Act-On Connect is now fully operational.
Posted Mar 15, 2023 - 17:17 PDT
This incident affected: Act-On Connect.