Degraded Email Performance on AORPCI3 Server

Incident Report for Act-On Software

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 12:55 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 10:52 PDT

Investigating

We are currently investigating a slowness issue impacting email performance for customers on the AORPCI3 server. Our team is actively working on a resolution, and further updates will be shared as they become available.
Posted Jun 25, 2025 - 09:27 PDT
This incident affected: Act-On Application.