CRM Sync Delays

Incident Report for Act-On Software

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 10:12 PST

Investigating

We are aware of delays in data syncing between Act-On and some CRMs. Our engineering team are actively working to resolve the issue as soon as possible.
Posted Mar 05, 2025 - 09:16 PST
This incident affected: CRM Connectors (SugarCRM Connector, Microsoft Dynamics Connector, Salesforce Connector).