FTP Unavailable
Incident Report for Act-On Software
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 04:21 PDT
Investigating
We have received reports that FTP service is currently unavailable.

Our team is investigating this issue. We will provide updates here as soon as we have them.
Posted Jun 09, 2020 - 03:10 PDT
This incident affected: FTP Connector.