Our Legacy Email Composer is currently unavailable

Incident Report for Act-On Software

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 12:28 PDT

Monitoring

Our engineering team has implemented a fix for the issue affecting the Legacy Email Composer and is now monitoring to ensure everything remains stable.
Posted Oct 30, 2025 - 10:03 PDT

Identified

Our engineering team has pinpointed the issue with the Legacy Email Composer and is already working on a fix to get everything back up and running.

We’ll keep you updated as soon as we have more news
Posted Oct 30, 2025 - 09:24 PDT

Investigating

We’re currently experiencing issues with our Legacy Email Composer. Our engineering team is actively investigating and working to restore full functionality. Updates will be shared here as they become available.
Posted Oct 30, 2025 - 08:28 PDT
This incident affected: Act-On Application.