Act-On Forms Fail to Load on Some Accounts
Incident Report for Act-On Software
Resolved
This incident has been resolved.
Posted Nov 11, 2019 - 03:55 PST
Investigating
We have received reports that Act-On forms on some accounts are failing to load.

Our team is investigating this issue as our top priority. We will provide updates here soon.
Posted Nov 10, 2019 - 23:14 PST
This incident affected: Form Submissions.