Delay with the sending of emails
Incident Report for Act-On Software
Resolved
We have resolved this issue. If you continue to experience this problem, please let our support team know at https://connect.act-on.com/hc/en-us/requests/new so we can investigate further.
Posted Oct 16, 2020 - 04:18 PDT
Monitoring
We have confirmed that the delays were for customers located in our EMEA datacentres only (ci20x and ci30x). Emails are currently being sent out as normal and we are monitoring the situation.
Posted Oct 16, 2020 - 03:38 PDT
Investigating
We are currently seeing issues with delayed email sending and our team is investigating this issue.

We will provide updates here as soon as we have them.
Posted Oct 16, 2020 - 01:50 PDT
This incident affected: Email Sending.