Delayed Email Sends
Incident Report for Act-On Software
Resolved
We have resolved this issue. If you continue to experience this problem, please let our support team know at https://connect.act-on.com/hc/en-us/requests/new so we can investigate further.
Posted Jun 12, 2020 - 08:54 PDT
Identified
We have confirmed the issue of some messages not sending and some lists not uploading. We have identified the issue and a fix will be deployed at 8:45am PT.
Posted Jun 12, 2020 - 08:38 PDT
Investigating
We have received reports that emails are currently delayed in being sent out at the moment.

Our team is investigating this issue. We will provide updates here as soon as we have them.
Posted Jun 12, 2020 - 06:59 PDT
This incident affected: Email Sending.